Warum funktioniert $vorname$nachname nicht ? - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Hagen (24 Beiträge) am Samstag, 17.Februar.2001, 23:09.
    Warum funktioniert $vorname$nachname nicht ?

      Hallo Stephan,
      vielen Dank für deine Antwort :-)

      Funktioniert wunderbar ---
      bis auf eine Kleinigkeit :
      wenn ich im Ausgabeformular mit :

      <a href="http://www.$vorname$nachname.de"</a>
      

      versuche einen Link zu erzeugen, bekomme
      ich als Ausgabe folgendes :


      http://www.Hans$nachname.de


      d.h. wenn ich $vorname$name OHNE Leerzeichen
      direkt hintereinander schreibe wird die 2.Variable
      nicht übergeben (MIT Leerzeichen dazwischen funktioniert es wunderbar)


      Weißt du was ich Falsch mache ---
      oder was ich anders machen muß ???
      (da ich im Link KEIN Leerzeichen brauchen kann)


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Hagen (24 Beiträge) am Samstag, 17.Februar.2001, 17:50.
    Wie übergebe ich Variablen aus einem Suchformular an BP ??

      Ich habe folgendes Problem

      Der Besucher soll in zwei Suchfeldern Namen
      und Vornamen eingeben, z.B.

      Name : Meyer
      Vorname : Hans



      Diese beiden Werte sollen dann irgendwie an BP übermittelt werden
      und auf der Ausgabeseite soll erscheinen :


      ---------------------------------------------------
      AUSGABESEITE

      Informationen zu Hans Meyer finden Sie unter :
      http://www.HansMeyer.de

      Bücher zu Hans Meyer finden Sie unter :
      http://www.bücher.de/HansMeyer.htm
      ---------------------------------------------------


      Weiß vielleicht jemand, wie man das hinbekommen kann.


      Vielen Dank im Voraus
      Hagen

     Antworten

    Beitrag von Stephan Hix (106 Beiträge) am Samstag, 17.Februar.2001, 18:09.
    Re: Wie übergebe ich Variablen aus einem Suchformular an BP ??

      Hallo Hagen!

      So sollte das Formular aussehen:

      <form method="post" action="Pfad_zur_BP-Datei" name="Formularname" enctype="multipart/form-data">
        <table width="95%" border="0" cellpadding="2" cellspacing="0">
          <tr bgcolor="AAd2AA"> 
            <td colspan="2">Ihre Eingabe:</td>
          </tr>
          <tr> 
            <td width="18%" bgcolor="ffffee">Vorname</td>
            <td width="82%" bgcolor="ffffee"> 
              <input type="text" name="vorname=" maxlength="25" size="25">
            </td>
          </tr>
          <tr> 
            <td width="18%" bgcolor="ffffee">Nachname</td>
            <td width="82%" bgcolor="ffffee"> 
              <input type="text" name="nachname=" size="25" maxlength="25">
            </td>
          </tr>
          <tr> 
            <td colspan="2" bgcolor="ffffee">
              <input type="submit" name="submit" value="Weiter">
              <input type="reset" name="reset" value="Zur&uuml;cksetzen">
            </td>
          </tr>
        </table>
      </form>
      


      Die Datei, die das ganze auswerten soll, bekommt dann die Variablen $vorname und $nachname geliefert und wird über action= im <form>-Tag aufgerufen.

      Den HansMeyer-Link oben erzeugst Du dann so:

      <a href="http://www.$vorname$nachname.de">http://www.$vorname$nachname.de</a>
      


      Gruß
      Stephan

     Antworten

    Beitrag von Hagen (24 Beiträge) am Samstag, 17.Februar.2001, 23:09.
    Warum funktioniert $vorname$nachname nicht ?

      Hallo Stephan,
      vielen Dank für deine Antwort :-)

      Funktioniert wunderbar ---
      bis auf eine Kleinigkeit :
      wenn ich im Ausgabeformular mit :

      <a href="http://www.$vorname$nachname.de"</a>
      

      versuche einen Link zu erzeugen, bekomme
      ich als Ausgabe folgendes :


      http://www.Hans$nachname.de


      d.h. wenn ich $vorname$name OHNE Leerzeichen
      direkt hintereinander schreibe wird die 2.Variable
      nicht übergeben (MIT Leerzeichen dazwischen funktioniert es wunderbar)


      Weißt du was ich Falsch mache ---
      oder was ich anders machen muß ???
      (da ich im Link KEIN Leerzeichen brauchen kann)

     Antworten

    Beitrag von Stephan Hix (106 Beiträge) am Sonntag, 18.Februar.2001, 10:46.
    Re: Warum funktioniert $vorname$nachname nicht ?

      Wie baust Du die Zeile auf? In einem HTNL-Programm-Abschnitt oder in einem Perl-Teil? Ist das exakt der Code den Du verwendest? Wirklich doppelte statt einfache Anführungszeichen?

      Die sicherste Antwort, die ich Dir geben kann, ohne das alles zu wissen, ist diese

      <perl>
      $linkname=$vorname.$name;
      </perl>
      

      Du bekommst dann mit $linkname die Ausgabe HansMeyer

      Noch eleganter wird es mit
      $linkname=lc($linkname);
      

      Dann wird nämlich alles klein geschrieben, wie sich das für eine URL eigentlich gehört...


      Gruß
      Stephan

     Antworten


     
 Liste der Einträge von 64800 bis 64950:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.11s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!