Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 14:04.
    Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      Das hilft mir aber doch nicht weiter.
      Ich möchte den Pfad ja mit ==München eingeben können.


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Tini (69 Beiträge) am Mittwoch, 1.Juli.2015, 13:23.
    Problem bei Verlinkung von Template

     Antworten

    Beitrag von Sander (8058 Beiträge) am Mittwoch, 1.Juli.2015, 23:21.
    Re: Problem bei Verlinkung von Template

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 09:09.
    Re: Re: Problem bei Verlinkung von Template

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 12:13.
    Re: Re: Problem bei Verlinkung von Template

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 12:23.
    Re: Re: Re: Problem bei Verlinkung von Template

      Hallo Richard,

      das soll aber automatisch gehen, daher dachte ich das irgendwie mit regex zu machen :-(
      Tini

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 12:37. WWW: posaunenchor-rhoden.de
    Re: Re: Re: Re: Problem bei Verlinkung von Template

      Das Verfahren kennst Du doch schon:

      <perl>
      $Ortlink2="München";
      out"$Ortlink2<br>";
      

      $Ortlink2=~ s/ü/%FC/g;

      out"$Ortlink2<br>";
      </perl>
      

      Brauchst Du beide Umsetzungen?

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 12:51.
    Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      So klappt das aber nicht :-(
      Bin ich so blond??


      <loop db=daten code=perl>
      

      $Ortlink = $Ort;
      $Ortlink=~ s/ü/%FC/g;
      $Ortlink=~ s/ü/ue/g;
      

      out <<EOF;

      $Name - $Ort -  /$Ortlink
      <hr>
      EOF
      </loop>
      

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 13:03.
    Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 13:54.
    Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 14:01.
    Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 14:04.
    Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      Das hilft mir aber doch nicht weiter.
      Ich möchte den Pfad ja mit ==München eingeben können.

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 14:28.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      Zeig doch mal mehr von Deinem Skript. Insbesondere wie Du den Link bastelst.

      Also, wie Du den Inhalt von $Ort (mit Umwandlung) als Parameter dort einbaust.

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 15:13.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      Das ist mein ganzes Template:
      <!DOCTYPE html>
      <html>
       <head>
      

      <style>
      .accordion {padding: 2px; background: #eee; border: 1px solid silver;
      }
      .accordion div {
          height: 0;
          overflow: hidden;
          transition: height 500ms ease-in 0s;
          font-size: 0.8em;
          margin-top: -500px;
          padding-top: 500px;
      }
      .accordion > a {
          background: none repeat scroll 0 0 #222;
          color: #FFFFFF;
          display: block;
          margin-bottom: 1px;
          padding: 5px;
          text-decoration: none;
          text-transform: uppercase;
      }
      .accordion div:target {
          height: 100px;
      }
      </style>
      
       </head>  <body> <div class="accordion"> <loop db=daten code=perl>

      $Ortlink = $Ort;
      $Ortlink=~ s/ü/%FC/g;
      $Ortlink=~ s/ü/ue/g;
      

      out <<EOF;

      <div id="accord$_id"><p>$Name - $Ort</div><a href="#accord$_id">$Ortlink</a>
      

      EOF
      </loop>		
      </div>
      
       </body>
      </html>




      Bei Berlin geht`s ja, so will ich das auch mit München, Düsseldorf, Göttingen, etc. machen:
      http://baseportal.de/cgi-bin/baseportal.pl?htx=/tini1972/orte/index&Ort==Berlin

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 15:47.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      So ganz erschließt sich mir Dein Problem jetzt nicht (mehr). Mag sein, dass ich da was übersehe.

      Hilft es Dir weiter, wenn Du hier

       <div id="accord$_id"><p>$Name - $Ort</div><a href="#accord$_id">$Ortlink</a>
      

      $Ortlink durch $Ort ersetzt?

       <div id="accord$_id"><p>$Name - $Ort</div><a href="#accord$_id">$Ort</a>
      

      Die Funktionalität sollte erhalten bleiben und die "richtigen" Ortsnamen ausgegeben werden.


      Wo ist dieser Link

      http://baseportal.de/cgi-bin/baseportal.pl?htx=/tini1972/orte/index&Ort==Berlin

      in Deinem Template, auf der Seite bzw. wie willste den bauen?

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 15:58.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      Der Link wird dann nur als ganz normales <a href... eingesetzt.

      <a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/tini1972/orte/index&Ort==Berlin">Berlin</a>
      

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 16:06.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

       <a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/tini1972/orte/index&Ort==$Ortlink">$Ort</a>
        "Ich möchte den Pfad ja mit ==München eingeben können."
      

      Oder doch per Hand? ==München geht wohl nicht. Aber ==M%FCnchen, also

       <a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/tini1972/orte/index&Ort==M%FCnchen">München</a>
      

     Antworten

    Beitrag von richard (1160 Beiträge) am Donnerstag, 2.Juli.2015, 16:07.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

       <a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/tini1972/orte/index&Ort==$Ortlink">$Ort</a>
      

      "Ich möchte den Pfad ja mit ==München eingeben können."

      ... ... ....

     Antworten

    Beitrag von Tini (69 Beiträge) am Donnerstag, 2.Juli.2015, 17:49.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      DANKE :-)

     Antworten

    Beitrag von Sander (8058 Beiträge) am Donnerstag, 2.Juli.2015, 14:21.
    Re: Re: Re: Re: Re: Re: Re: Problem bei Verlinkung von Template

      das ist utf8-urlcodiert, das versteht bp nicht (ohne weiteres)

     Antworten


     
 Liste der Einträge von 1350 bis 1500:Einklappen Zur Eingabe 
Neueste Einträge << 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.21s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!