Re: Re: Re: Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt. - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 18:37. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Keine Ursache, gern geschehen, aber

      convert_acute gibt es auch nicht...;)

      nur die in dem von mir geposteten Link beschriebenen Möglichkeiten, in diesem Fall also convert_html

      Vermutlich sind Deine anderen Sachen bei bp für die Konvertierung nicht implementiert, vielleicht kann Sander die ja noch bei bp intern in dem Code für die Umwandlungen einbauen, das steht aber außerhalb meiner Befugnisse, ich kann nur innerhalb der bp-Möglichkeien versuchen, Lösungen aufzuzeigen...;)


      Gruesse

      Claus


    Ihre Antwort:

    Name: EMail: EMail bei Antwort? WWW:
    Titel:
    Text:

    Neuer Eintrag


 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Reiner (305 Beiträge) am Mittwoch, 16.Januar.2013, 12:55. WWW: www.biker-motorrad-hotel.de
    Zeichen werden falsch dargestellt.

      Hallo

      folgendes Problem liegt vor und ich hoffe Ihr könnt mir helfen.

      In meine Website binde ich basportal Seiten ein

      Hier ein Beispiel:

      http://www.biker-motorrad-hotel.de/?Motorrad_Hotel:Deutschland:10000-19999

      Der Zeichensatz hier ist utf-8

      Das CMS ist CMSimple.

      Die Datei wird so eingebunden:

      #CMSimple $output.=geturl('http://www.daten-banken.de/cgi-bin/baseportal.pl?htx=/Hotel/bh_leer&db=Hotell&cmd=list&range=20,&Freigegeben==1&Land~=D-00000'); # 
      

      Leider werden die Umlaute etc. falsch dargestellt.

      Jetzt habe ich versucht die bh_leer anzupassen:

      <perl>
      $_header="Content-type: text/html; charset=UTF-8\n\n";
      out "<meta http-equiv='Content-Type' content='text/html; charset=utf-8'>";
      

      if($cmd eq "all"){
        $ENV{QUERY_STRING}=~s#htx=/Hotel/bh_leer&?##;
        $_link=~s#htx=/Hotel/bh_leer#htx=/Hotel/biker_motorrad_hotel#;
        $_header="Location: $_link&$ENV{QUERY_STRING}\n\n";
        die;
      }
      </perl>
      <do action=all mail_put=reiner@vt600c.com mail_mod=EMail mail_del=*,EMail db=Hotel range^=0,500 sort=Postleitzahl searchfields=Name,Land,Bundesland,Region,Postleitzahl,Ort,Homepage,E-Mail,Id listfields=Name,Postleitzahl,Ort allfields=Name,Land,Bundesland,Region,Postleitzahl,Ort,Homepage,Strasse,E-Mail,Telefon,Fax.,Beschreibung,Preis/Euro,Tourenplaner formfields=Region,Postleitzahl,Ort,Homepage,Strasse,E-Mail,Telefon,Fax.,Beschreibung,Preis/Euro,Hits,Tourenplaner,Freigegeben showamount=all,sel selectbrowse=no buttonbrowse=no pagebrowse=no indexbrowse=no border=0 spacing=1 gridcolor=AFBFCF dataface=Arial datasize=2 datacolor=003366 databack=F9FAFB databack2=E2E8EE headface=Arial headsize=2 headcolor=003366 headback=AFBFCF textface=Arial textsize=2 textcolor=003366 listtype=list language=de detail=link search=no input=no listtype=list> 
      

      Leider hat das auch nichts gebracht.

      Hat vielleicht jemand bitte eine Lösung für mein Problem?

      Danke schon mal...

      Reiner

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 13:34. WWW: hammoniaweb.com
    Re: Zeichen werden falsch dargestellt.

      versuch bei der Ausgabe im Template mal folgendes im Head-Bereich:


      <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
      

      hth

      Gruesse

      Claus

     Antworten

    Beitrag von Reiner (305 Beiträge) am Mittwoch, 16.Januar.2013, 13:45. WWW: www.biker-motorrad-hotel.de
    Re: Re: Zeichen werden falsch dargestellt.

      Hallo Claus,

      danke für Deine Hilfe.

      Eigentlich habe ich im Tempate gar keine Angaben zum charset gemacht, da dieses nur zum includen in meine bestehende Seite gedacht ist und ich so doppelte meta Angaben erhalten würde.

      Ich habe mir die Datenbank aber einmal als csv gedownloadet und am Schluß steht eh Content-type: text/html; charset=iso-8859-1.

      Trotzallem habe ich das jetzt so gemacht:

      <html xmlns="http://www.w3.org/1999/xhtml">
       <head>
      <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
      <perl>
      if($cmd eq "all"){
        $ENV{QUERY_STRING}=~s#htx=/Hotel/bh_leer&?##;
        $_link=~s#htx=/Hotel/bh_leer#htx=/Hotel/biker_motorrad_hotel#;
        $_header="Location: $_link&$ENV{QUERY_STRING}\n\n";
        die;
      }
      </perl>
      
       </head>  <body> <do action=all mail_put=reiner@vt600c.com mail_mod=EMail mail_del=*,EMail db=Hotel range^=0,500 sort=Postleitzahl searchfields=Name,Land,Bundesland,Region,Postleitzahl,Ort,Homepage,E-Mail,Id listfields=Name,Postleitzahl,Ort allfields=Name,Land,Bundesland,Region,Postleitzahl,Ort,Homepage,Strasse,E-Mail,Telefon,Fax.,Beschreibung,Preis/Euro,Tourenplaner formfields=Region,Postleitzahl,Ort,Homepage,Strasse,E-Mail,Telefon,Fax.,Beschreibung,Preis/Euro,Hits,Tourenplaner,Freigegeben showamount=all,sel selectbrowse=no buttonbrowse=no pagebrowse=no indexbrowse=no border=0 spacing=1 gridcolor=AFBFCF dataface=Arial datasize=2 datacolor=003366 databack=F9FAFB databack2=E2E8EE headface=Arial headsize=2 headcolor=003366 headback=AFBFCF textface=Arial textsize=2 textcolor=003366 listtype=list language=de detail=link search=no input=no listtype=list>
       </body>
      </html>

      Hat auch nicht weitergeholfen.

      Ich brauche das Template convertiert in utf-8

      Viele Grüße

      Reiner

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 17:29. WWW: hammoniaweb.com
    Re: Re: Re: Zeichen werden falsch dargestellt.

      ich arbeite eigentlich eher nicht mit utf-8, daher auch nur rudimentäre Kenntnisse...;)

      versuch mal so im template:


      $_header="Content-Type: text/html; charset=iso-8859-1\n\n";
      

      hth

      Gruesse


      Claus

     Antworten

    Beitrag von Reiner (305 Beiträge) am Mittwoch, 16.Januar.2013, 17:37.
    Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Hallo Claus,

      klappt leider auch nicht.

      Ich habe jetzt alle Zeichen per Hand umgestellt.
      Also aus ä &auml; etc. gemacht.

      Aber nochmals vielen Dank für Deine Hilfe.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 17:47. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      umwandeln wäre vermutlich dann auch so möglich gewesen?


      $Text = convert_html($Text);
      


      siehe:


      http://doku.baseportal.de/56.html

      wie gesagt, brauchte ich eigentlich noch nicht selbst.


      Gruesse


      Claus

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 18:02. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt./Nachtrag

      Vielleicht kannst Du das aber schon bei der Erfassung/Eingabe machen?


      <perl>
      if(%_put){
      $dein_Text_feld = convert_html($dein_Text_feld);
      }
      </perl> 
      <do action=all db=dein_db_name usw.....> 
      


      Wie gesagt, mal probieren...;)

      hth


      Gruesse

      Claus

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 17:51. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      eventuell auch direkt im

      <do action=all db=dbname convert_html=Das_feld_fuer_die_konvertierung usw....>
      

      mußt du mal mit einer Probe-Geschichte testen...

      Gruesse

      Claus

     Antworten

    Beitrag von Reiner (305 Beiträge) am Mittwoch, 16.Januar.2013, 18:03.
    Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Super, das klappt....

      Fast. Umlaute werden zwar geändert, jedoch nicht

      &acute;	´
      &Eacute; É etc.
      

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 18:12. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Vielleicht hat Sander ja noch eine weiterführende Idee oder kann diese Zeichen noch intern bei bp ergänzen?

      Gruesse

      Claus

     Antworten

    Beitrag von Reiner (305 Beiträge) am Mittwoch, 16.Januar.2013, 18:17.
    Re: Re: Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Ich habs mal so probiert:

      <do action=all db=dbname convert_acute=Das_feld_fuer_die_konvertierung usw....>
      

      Klappt leider nicht.

      Ich werde diese komischen Zeichen rausnehmen. Braucht kein Mensch... ;-)

      Mit den Umlauten hast mir aber schon sehr weitergeholfen. Danke!

      Grüße

      Reiner

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 18:37. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Keine Ursache, gern geschehen, aber

      convert_acute gibt es auch nicht...;)

      nur die in dem von mir geposteten Link beschriebenen Möglichkeiten, in diesem Fall also convert_html

      Vermutlich sind Deine anderen Sachen bei bp für die Konvertierung nicht implementiert, vielleicht kann Sander die ja noch bei bp intern in dem Code für die Umwandlungen einbauen, das steht aber außerhalb meiner Befugnisse, ich kann nur innerhalb der bp-Möglichkeien versuchen, Lösungen aufzuzeigen...;)


      Gruesse

      Claus

     Antworten

    Beitrag von Sander (8082 Beiträge) am Mittwoch, 16.Januar.2013, 18:52.
    Re: Zeichen werden falsch dargestellt.

      ganz eigentlich musst du die Werte schon in utf8 abspeichern. dann kannst du bei der ausgabe auch den header utf8 setzen und es wird durchgängig richtig angezeigt. sollten noch im template umlaute sein, muss auch der text des templates utf8 sein. das kannst du aber nur in einem externen editor einstellen.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 19:10. WWW: hammoniaweb.com
    Re: Re: Zeichen werden falsch dargestellt.

      Gilt das auch für Liz V2?

     Antworten

    Beitrag von Sander (8082 Beiträge) am Mittwoch, 16.Januar.2013, 20:20.
    Re: Re: Re: Zeichen werden falsch dargestellt.

      ja klar - problem ist, das man den browser bei der eingabe auf codierung von utf8 einstellen muss - fürs template, wie auch bei der datenbank. bei der datenbnak ist dies ja über ein eigenes <do action=all> + header utf8 möglich. beim template musst du das warscheinlich jedesmal über die menüleiste (Ansicht) einstellen. oder bei lizenz per ftp hochladen aber in einem utf8 fähigen editor programmieren.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 20:37. WWW: hammoniaweb.com
    Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Hi Sander,


      gerade mal was getestet...;)


      http://jobmarder.de/cgi-bin/baseportal.pl?htx=/probe/test


      Im Template habe ich jetzt utf-8 eingestellt...


      der obere Texteintrag wurde damals mal zu testzwecken mit iso 8859-1 eingegeben und den unteren habe ich jetzt eben gerade mal im Browser mit utf-8 eingegeben, es gibt aber völlig unterschiedliche Darstellungen, was für mich auch eigentlich klar ist, denn unterschiedliche Zeichensätze bringen unterschiedliche Ergebnisse....

      Insofern denke ich, über convert_html bringt man da bei der Ausgabe beides anscheinend auf ein Level...

      Kann mich da natürlich auch irren, nobodys perfect...;)

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 16.Januar.2013, 21:01. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

     Antworten

    Beitrag von Sander (8082 Beiträge) am Donnerstag, 17.Januar.2013, 16:09.
    Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      mit convert_html konvertiert es ja keine zeichensätze sondern die umlaute in entities. Da bei bp aber auch nicht alle hinterlegt sind (eigentlich nur deutsche), hapert es dann irgendwo. Mischmasch in der Db ist generell immer schlecht. im zweifel muss man diese umspeichern. Bei neuen Anwendungen hab ich mir angewöhnt, immer alles in utf8 zu machen. Da hast du bei verschiedenen Sprachen den wenigsten Stress.

      Wer php in bp nutzen kann, hat den vorteil das konvertieren php überlassen zu können, was auch meist mit den unterschiedlichen Befehlen klappt.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Samstag, 19.Januar.2013, 20:45. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Zeichen werden falsch dargestellt.

      Klar, umspeichern macht schon Sinn, aber für die Ausgabe kommt man mit dem convert zumindest übergangsweise zurecht.

      Ist sicherlich nicht der Königsweg, aber immerhin, es funzt bei der ausgabe...;)


      Gruesse

      Claus

     Antworten


     
 Liste der Einträge von 3150 bis 3300:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.56s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!