Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Markus (16 Beiträge) am Mittwoch, 14.November.2012, 08:00.
    Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      Ja, ganz normal


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von markus (993 Beiträge) am Dienstag, 13.November.2012, 18:29.
    problem bei abfrage nach datum in einer lizenz - datum~=dezember

      hallo,

      ich habe ein abfrageproblem in einer lizenz:

      ich frage eine db nach einträgen ab:
      <loop db=res datum\>jetzt sort=datum code=perl>
      


      mit dem aufruf bekomme ich alle einträge für dezember 2012:
      /cgi-bin/baseportal.pl?htx=/tickets&datum~=dezember

      ... aber nur von 2012!
      wieso gibt er mir nicht auch einträge von 2013??

      rufe ich die seite so auf, bekomme ich alle angezeigt:
      /cgi-bin/baseportal.pl?htx=/tickets

      kann ich das irgendwie umgehen oder muss ich den jahreswechsel abwarten?

      markus

     Antworten

    Beitrag von Sander (8105 Beiträge) am Dienstag, 13.November.2012, 19:34.
    Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      datum ist ein ganz normales datumfeld?

     Antworten

    Beitrag von Markus (16 Beiträge) am Mittwoch, 14.November.2012, 08:00.
    Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      Ja, ganz normal

     Antworten

    Beitrag von markus (993 Beiträge) am Mittwoch, 14.November.2012, 10:40.
    Re: Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember



      zur veranschaulichung:

      so ist es aktuell, leider nur das laufende jahr:
      http://mehrwertpraemie.de/testticket1
      (so werden alle angezeigt)
      ergänze ich den link mit ~=dezember - alle im dezember


      ich hab mich mal an dem codeschnipsel aus dem forum versucht:
      http://mehrwertpraemie.de/testticket2

      klappt nicht ganz mit dem foreach :-)
      rein der link soll ja alle in der linken spalte anzeigen.
      bei linkergänzung von ~=dezember dann nur die des dezember


      <perl>
      get "vadatum\>jetzt sort=vadatum", "buch", "ergebnis";
      

      while(get_next("ergebnis"))

      {
        $va_datum=datum("$vadatum", "Tag0.Monat0.Jahr2");
        $monat=datum("$vadatum","Monat");
      $text{$monat}.=<<EOF
      $titel ($va_datum)<br>
      

      EOF
      }
      

      foreach $monat (sort keys %text)

      {
        $monatname=datum("$monat.2000","Monatname");
      out <<EOF;
      <li class="$_id"><a class="sidebarmenuselect_noselect" href="#"><span></span><h6>$text{$monat}</h6></a></li>
      EOF
      }
      </perl>
      

     Antworten

    Beitrag von Sander (8105 Beiträge) am Mittwoch, 14.November.2012, 17:53.
    Re: Re: Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      ich speichere mir in so einem Fall immer das Datum ohne Jahr ab (zb für Geburtstage). Dann kannst du nach diesem Feld suchen, aber gibst das andere Datumfeld inkl Jahr aus...

     Antworten

    Beitrag von Markus (16 Beiträge) am Mittwoch, 14.November.2012, 19:47.
    Re: Re: Re: Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      ... also ein weiteres Feld bei der Eingabe
      für den Monat?

     Antworten

    Beitrag von Sander (8105 Beiträge) am Mittwoch, 14.November.2012, 20:39.
    Re: Re: Re: Re: Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      si

     Antworten

    Beitrag von Claus (4644 Beiträge) am Donnerstag, 15.November.2012, 20:23. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      oder in einer get-Schleife über unterschiedliche Vars mit substr rausfiltern...

      Gruesse

      Claus

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 14.November.2012, 06:58. WWW: hammoniaweb.com
    Re: problem bei abfrage nach datum in einer lizenz - datum~=dezember

      Hi Markus,

      steht doch in der Doku:

       In einem "normalen" Datumsfeld können Sie also nicht einfach alle Einträge mit dem Monat "Juni" egal in welchem Jahr ausgeben lassen. Ein Abfrage wie...
      

      Datum~=juni

      ...ist dennoch möglich - sie liefert jedoch alle Einträge mit Monat "Juni" des aktuellen Jahres.

      Bezieht sich, wie man sieht, nur auf das aktuelle Jahr...

      hth

      Gruesse

      Claus

     Antworten


     
 Liste der Einträge von 3600 bis 3750:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.09s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!