Re: Nochmal Netscape+Explorer (vielleicht doch bug) - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Manticor (85 Beiträge) am Montag, 13.November.2000, 22:40.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      Ui, schwer zu sagen ohne Insider-Wissen. Leg' doch mal den Quelltext auf Deiner Seite ab (z.B. http://.../template.txt o.ä.). Vielleicht weiss Christoph da Rat.
      Für mich sieht das nach einer perl-Anweisung aus, die das erzeugt, falls ja versuch's mal mit "", um deren Ausgabe zu unterdrücken. Steht glaub ich auch irgendwo in den FAQs. Moment...
      http://www.baseportal.de/cgi-bin/baseportal.pl?htx=/baseportal/faq#61
      oder das item drüber...
      Hoffe es hilft Dir weiter.

      Grüsse, Manti


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Claus (4644 Beiträge) am Montag, 13.November.2000, 22:23.
    Nochmal Netscape+Explorer (vielleicht doch bug)

      Danke Christoph + Manticor,
      es lag tatsächlich an nicht geschlossenen tables. habe aber jetzt etwas merkwürdiges entdeckt: schreibe ich ein template zur listausgabe ohne schnickschnack, dann erscheint alles sauber in beiden browsern:
      http://baseportal.de/cgi-bin/baseportal.pl?htx=/CSeifried/bglist2
      verziere ich aber das template lediglich mit einer überschrift und rahmen, dann kommt beim explorer müll raus und bei netscape wird die überschrift unterdrückt, aber die liste korrekt dargestellt:
      http://baseportal.de/cgi-bin/baseportal.pl?htx=/CSeifried/bglist
      bei ansehen des quelltextes sah ich dann, dass baseportal beim ersten <loop> für jeden gelesenen satz jeweils ein "<tr></tr>" erzeugt, bei mir also über 600, und damit die leere Seite beim explorer erzeugt.
      gibt es da einen trick, dass zu umgehen.
      gruss claus

     Antworten

    Beitrag von Manticor (85 Beiträge) am Montag, 13.November.2000, 22:40.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      Ui, schwer zu sagen ohne Insider-Wissen. Leg' doch mal den Quelltext auf Deiner Seite ab (z.B. http://.../template.txt o.ä.). Vielleicht weiss Christoph da Rat.
      Für mich sieht das nach einer perl-Anweisung aus, die das erzeugt, falls ja versuch's mal mit "", um deren Ausgabe zu unterdrücken. Steht glaub ich auch irgendwo in den FAQs. Moment...
      http://www.baseportal.de/cgi-bin/baseportal.pl?htx=/baseportal/faq#61
      oder das item drüber...
      Hoffe es hilft Dir weiter.

      Grüsse, Manti

     Antworten

    Beitrag von Christoph Bergmann (8110 Beiträge) am Dienstag, 14.November.2000, 00:07.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      Manticor hat mal wieder alles gesagt ;-)

      Schmeiss doch einfach mal den entsprechenden loop-Teil hier rein...

     Antworten

    Beitrag von Claus (4644 Beiträge) am Dienstag, 14.November.2000, 00:36.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      da isser:

      <HTML><HEAD><TITLE>Test</TITLE></HEAD>
      

      <BODY vLink=#000099 link=#990000 bgColor=#000000>

      <center>
      

      <TABLE cellSpacing=0 cellPadding=1 border=1 align=center bgcolor=#e8ecc8 width=100%>
          <TR bgColor=#990000><TH><FONT face=verdana color=#ffffff size=2><B> Gesamtanzeige</B></FONT></TH></TR>
          <TR><TD><FONT face=verdana color=#000000 size=3> </font></TD></TR>
      
          <TR><TD> <!-------------- Baseportal Anfang ----------------------------------------------------------------------------------> <loop db=bgdat></loop>

      <perl>
      out " ";
      if($_range >= 10)
       {
        $bereich=$_range-10;
       }
        else
       {
        $bereich=0;
       }
      </perl>
      

      <a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/CSeifried/bglist&range=out $bereich;</perl>,10"><img src="http://www.guidepark.de/images/prev.gif" border=0 alt="zurück"></a>

      <perl>
      out " ";
      if($_range <= $_amount_all-10)
       {
        $bereich=$_range+10;
       }
        else
       {
        $bereich=$_range;
       }
      </perl>
      

      <a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/CSeifried/bglist&range=out $bereich;</perl>,10"><img src="http://www.guidepark.de/images/next.gif" border=0 alt="weiter"></a>

      <table border=1 cellspacing=1 cellpadding=2>
      <TR bgcolor=#445577>
        <TD width=15% align=left><FONT face="verdana" color=#FFFFFF size=2> Branche</FONT></TD>
        <TD width=25% align=left><FONT face="verdana" color=#FFFFFF size=2> Name</FONT></TD>
        <TD width=15% align=left><FONT face="verdana" color=#FFFFFF size=2> Strasse</B></FONT></A></TD>
        <TD width=3% align=left><FONT face="verdana" color=#FFFFFF size=2> Nr</FONT></TD>
      </TR>
      

      <do db=bgdat action=input>
      <loop db=bgdat sort^=Branche,Name range^=0,10>
      <TR bgcolor=#bbccee>
         <td><font bgcolor=#000033 face="verdana" size=2> $Branche</td>
         <td><font bgcolor=#000033 face="verdana" size=2><a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/CSeifried/bgdetail&cmd=all&Id==$_id">$Name</a></td>
         <td><font bgcolor=#000033 face="verdana" size=2> $Strasse</td>
         <td><font bgcolor=#000033 face="verdana" size=2> $Nr</td>
      </tr>
      </loop>
      </table>
      <p><font face="verdana" size=1><b></b>
      <p> [<a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/bgadd&uid=CSeifried&db=bgdat&cmd=do_add">
      Neuer Eintrag</a>] 
      </font>
      

      <!-------------- Baseportal Ende ------------------------------------------------------------------------------------>

      </TD></TR>
      </TABLE>
      

      </body></html>

     Antworten

    Beitrag von Manticor (85 Beiträge) am Dienstag, 14.November.2000, 00:46.
    Re: Nochmal Netscape+Explorer: Autsch is der lang

      Hi, deswegen meinte ich, dass Du den Text auf die Homepage selber stellst, weil man den aus dem Forum schlecht rauskopieren kann und er durch das Layout auch nicht gerade leserlicher wird, aber mal sehen:

     Antworten

    Beitrag von Manticor (85 Beiträge) am Dienstag, 14.November.2000, 01:15.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      Hm, also dieses <tr> </tr> Feuerwerk wird in beiden Templates abgefeuert.
      Bin ein wenig überfragt. Vorschlag:
      mach mal aus deinem ersten Loop:<loop code=perl db=bgdat>""</loop>
      Das müsste wenigstens das beheben. Aber ob es der Verursacher des Überschriftschluckens ist, kann ich nicht genau sagen.

      Übrigens:
      <TD width=15% align=left><FONT face="verdana" color=#FFFFFF size=2> Strasse</B></FONT></A></TD>
      Wo kommen hier </B> und </a> her?
      

      Viel Erfolg noch bei der Suche!
      Manti

     Antworten

    Beitrag von Claus (4644 Beiträge) am Dienstag, 14.November.2000, 01:31.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      danke manti,
      aber ich geh jetzt in die heia
      sitze schon seit heute morgen vor der kiste.
      gruss und bis morgen
      claus

     Antworten

    Beitrag von Christoph Bergmann (8110 Beiträge) am Dienstag, 14.November.2000, 22:57.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      Nanu, mir ist so, als hätte ich darauf schonmal geantwortet?

      Also:

      <a href="http://baseportal.de/cgi-bin/baseportal.pl?htx=/CSeifried/bglist&range=out $bereich;</perl>,10"><img src="http://www.guidepark.de/images/next.gif" border=0 alt="weiter"></a>
      

      ist definitiv falsch, wg. "out $bereich</perl>" - es fehlt das öffnende "<perl>", was es aber sowieso nicht braucht, weil einfach die Angabe der Variablen reicht, also: ...&range=$bereich,10"><img...

      Das:

      <loop db=bgdat></loop>
      

      würde ich mal als Übeltäter für die <tr>'s ausmachen - was genau soll diese Anweisung denn machen? Du gehst durch alle Einträge der Datenbank ("loop") aber Du machst nichts damit...? Wozu ist die Anweisung dann da?

      Dass dabei Müll rauskommt, wenn nichts in der Schleife steht liegt daran (schätze ich mal), dass das Prg. einfach die letzte Ausgabe immer wieder ausgibt und zwar so oft wie Einträge in Deiner Datenbank stehen...

     Antworten

    Beitrag von Claus (4644 Beiträge) am Mittwoch, 15.November.2000, 17:26.
    Re: Nochmal Netscape+Explorer (vielleicht doch bug)

      Hi Christoph,

      hast mal wieder recht; kommt davon, wenn man kopiert (obwohl das eine funktionierende Anwendung war). Nachdem ich den Tip von Manti beherzigt habe( ein <Perl >dazu)und es funktioniertee, habe ich die loop-schleife jetzt ganz rausgeschmissen und jetzt klappts wie geschmiert. werde tastatur ruhen lassen und mich mal ausführlich mit der doku beschäftigen ;-)) jedenfalss habt ihr beiden bei jetzt auch Schampus (!?) gut
      gruss claus

     Antworten


     
 Liste der Einträge von 67800 bis 67950:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.42s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!