Re: Re: Re: Problem mit PW Bereich - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Bernd (209 Beiträge) am Montag, 18.Februar.2013, 15:31.
    Re: Re: Re: Problem mit PW Bereich

      Hallo,

      habe mich mal in der Doku mit dem get_next befasst und lag wirklich daran.
      Danke.

      Die Sache mit dem Passwortschutz ist ne feine Sache.
      Leider wird namerein und pwrein in der browserzeile immer angezeigt, wenn man z.B. einen Eintrag neu anlegt.


      Beim Login habe ich schon versucht mit input type=hidden:
      <input type=hidden name="namerein=" value="$namerein">
      <input type=hidden name="pwrein=" value="$pwrein">
      

      Das passte aber irgendwie nicht.

      Bernd






      <perl>
      

      if($namerein ne "")
      {
      
        get "Login==!$namerein", "nutzer";   if($Passwort ne "" && $Passwort eq $pwrein)   { do_all "db=...." , "namerein", "pwrein";
                        }else   {     out "<b>Anmeldung fehlgeschlagen!</b>";     $namerein="";
        }
      }

      if($namerein eq "")
      {
      

      out <<EOF;

      <form action="/cgi-bin/baseportal.pl?htx=$htx" method="post" enctype="multipart/form-data">
      <input type=hidden name="htx=" value="$htx">
      <table>
      <tr><td>Login:</td><td><input type="text" name="namerein="></td></tr>
      <tr><td>Passwort:</td><td><input type="password" name="pwrein="></td></tr>
      <tr><td colspan=2><input type=submit value="login"></td></tr>
      

      </table>


      </form>
      EOF
      

      }



      </perl>
      


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Bernd (209 Beiträge) am Freitag, 15.Februar.2013, 12:46.
    Problem mit PW Bereich

      Hallo,

      ich habe ein Problem mit ein passwortgeschützdem Bereich wenn ich die
      Daten mit mit do_all "db=........ ausgeben möchte.

      Es wird mir nur 1 Datensatz angezeigt, anstatt alle!
      Wo habe ich meinen Denkfehler?

      Vielen Dank
      Bernd




      <perl>
      

      if($namerein ne "")
      {
      
        get "Login==!$namerein", "nutzerdb";   if($Passwort ne "" && $Passwort eq $pwrein)   {

      get "sort=-", "meinedatenbank";

      out<<EOF;
      

      <table>
      <tr><td>Name</td><td>$vorname $nachname</td></tr>
      <tr><td>Strasse</td><td>$strasse</td></tr>
      <tr><td>PLZ/Ort</td><td>$plz $ort</td></tr>
      <tr><td>Email</td><td>$email</td></tr>
      <tr><td>Telefon</td><td>$telefon</td></tr>
      </table>
      EOF
        } else
        {
          out "<b>Anmeldung fehlgeschlagen!</b>";
          $namerein="";
      
        }
      }

      if($namerein eq "")
      {
      

      out <<EOF;

      <form action="/cgi-bin/baseportal.pl?htx=$htx" method="post" enctype="multipart/form-data">
      <input type=hidden name="htx=" value="$htx">
      <table>
      <tr><td>Login:</td><td><input type="text" name="namerein="></td></tr>
      <tr><td>Passwort:</td><td><input type="password" name="pwrein="></td></tr>
      <tr><td colspan=2><input type=submit value="einloggen"></td></tr>
      </body>
      </table>
      </form>
      EOF
      

      }


      </perl>
      

     Antworten

    Beitrag von Claus (4636 Beiträge) am Freitag, 15.Februar.2013, 13:37. WWW: hammoniaweb.com
    Re: Problem mit PW Bereich

      Wo ist denn dein do_all "db=

      ??

      Übrigens, bei dem get wird auch nur 1 DS ausgegeben, weil da ein hhile (get next... fehlt......


      siehe Doku:

      http://doku.baseportal.de/1393.html


      hth

      Gruesse

      Claus

     Antworten

    Beitrag von Bernd (209 Beiträge) am Freitag, 15.Februar.2013, 14:54.
    Re: Re: Problem mit PW Bereich

      Hallo Claus,

      das do_all will ich ja nicht.
      Ich möchte gerne die Daten per get holen und ausgeben.
      Da kann ich das ganze schöner darstellen.
      Schau mir das mit dem get next mal an.

      Danke
      Bernd

     Antworten

    Beitrag von Claus (4636 Beiträge) am Freitag, 15.Februar.2013, 15:01. WWW: hammoniaweb.com
    Re: Re: Re: Problem mit PW Bereich

      Keine Ursache.

      ist eigentlich recht einfach:


      <perl>
      if($namerein ne "")
      

      {

        get "Login==!$namerein", "nutzerdb";
        if($Passwort ne "" && $Passwort eq $pwrein)
        {
      get "sort=-", "meinedatenbank";
      while(get_next("meinedatenbank"))
      {
      out<<EOF;
      <table>
      

      <tr><td>Name</td><td>$vorname $nachname</td></tr>
      <tr><td>Strasse</td><td>$strasse</td></tr>
      <tr><td>PLZ/Ort</td><td>$plz $ort</td></tr>
      <tr><td>Email</td><td>$email</td></tr>
      <tr><td>Telefon</td><td>$telefon</td></tr>
      </table>
      EOF
      }
        } else
        {
          out "<b>Anmeldung fehlgeschlagen!</b>";
          $namerein="";
      
        } }

      if($namerein eq "")
      {
      out <<EOF;
      

      <form action="/cgi-bin/baseportal.pl?htx=$htx" method="post" enctype="multipart/form-data">
      <input type=hidden name="htx=" value="$htx">
      <table>
      <tr><td>Login:</td><td><input type="text" name="namerein="></td></tr>
      <tr><td>Passwort:</td><td><input type="password" name="pwrein="></td></tr>
      <tr><td colspan=2><input type=submit value="einloggen"></td></tr>
      </body>
      </table>
      </form>
      EOF
      }
      </perl>
      


      sollte so funktionieren...;)

      Gruesse

      claus

     Antworten

    Beitrag von Bernd (209 Beiträge) am Montag, 18.Februar.2013, 15:31.
    Re: Re: Re: Problem mit PW Bereich

      Hallo,

      habe mich mal in der Doku mit dem get_next befasst und lag wirklich daran.
      Danke.

      Die Sache mit dem Passwortschutz ist ne feine Sache.
      Leider wird namerein und pwrein in der browserzeile immer angezeigt, wenn man z.B. einen Eintrag neu anlegt.


      Beim Login habe ich schon versucht mit input type=hidden:
      <input type=hidden name="namerein=" value="$namerein">
      <input type=hidden name="pwrein=" value="$pwrein">
      

      Das passte aber irgendwie nicht.

      Bernd






      <perl>
      

      if($namerein ne "")
      {
      
        get "Login==!$namerein", "nutzer";   if($Passwort ne "" && $Passwort eq $pwrein)   { do_all "db=...." , "namerein", "pwrein";
                        }else   {     out "<b>Anmeldung fehlgeschlagen!</b>";     $namerein="";
        }
      }

      if($namerein eq "")
      {
      

      out <<EOF;

      <form action="/cgi-bin/baseportal.pl?htx=$htx" method="post" enctype="multipart/form-data">
      <input type=hidden name="htx=" value="$htx">
      <table>
      <tr><td>Login:</td><td><input type="text" name="namerein="></td></tr>
      <tr><td>Passwort:</td><td><input type="password" name="pwrein="></td></tr>
      <tr><td colspan=2><input type=submit value="login"></td></tr>
      

      </table>


      </form>
      EOF
      

      }



      </perl>
      

     Antworten

    Beitrag von Claus (4636 Beiträge) am Montag, 18.Februar.2013, 16:08. WWW: hammoniaweb.com
    Re: Re: Re: Re: Problem mit PW Bereich

      Welchen PW-Schutz aus der Bibliothek verwendest Du denn?


      Den alten von Christoph Bergmann?

      Dann probier mal den hier, hatte ich damals mal aufbauend darauf entsprechend geändert:

      e251 - Passwortschutz mit SID, Nutzerverwaltung für einen oder mehrere Datensätze von Claus (-Dieter Jürgens) am 22.2.2005, 14:27 (550)

      hth


      Gruesse

      Claus

      PS: vor ein paar Jahren habe ich da diverse Veränderungen vorgenommen, da bei Lizenzen in Version 2 noch kein baseportaleigener Passwortschutz möglich ist. Allerdings ist diese geänderte Version nicht frei verfügbar, sondern nur für eigene Sachen und Kunden bestimmt....

     Antworten

    Beitrag von Paßwortschutz (4 Beiträge) am Montag, 18.Februar.2013, 16:29.
    Re: Re: Re: Problem mit PW Bereich

     Antworten

    Beitrag von Claus (4636 Beiträge) am Montag, 18.Februar.2013, 18:09. WWW: hammoniaweb.com
    Re: Re: Re: Re: Problem mit PW Bereich

     Antworten

    Beitrag von Bernd (209 Beiträge) am Dienstag, 19.Februar.2013, 07:26.
    Re: Re: Re: Re: Re: Problem mit PW Bereich

      Ab Version 3, ok und für Version 2 gibt`s da nix?

     Antworten

    Beitrag von Paßwortschutz (4 Beiträge) am Dienstag, 19.Februar.2013, 07:44.
    Re: Re: Re: Re: Re: Problem mit PW Bereich

      Das hast Du schon gefunden.

     Antworten

    Beitrag von Bernd (209 Beiträge) am Dienstag, 19.Februar.2013, 08:32.
    Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      Danke!
      Dann muß ich halt mit der Übergabe von Passwort im Link leben.

      Schönen Tag!
      Bernd

     Antworten

    Beitrag von Paßwortschutz (4 Beiträge) am Dienstag, 19.Februar.2013, 09:07.
    Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      Du könntest es auch so umbauen, dass ein neutraler Wert wie eine Zahl in der URL angezeigt wird.

      Am einfachsten wäre aber wohl ein Update. Windows und Office hast du doch sicher auch nicht in einer Uraltversion auf dem Rechner. Oder?

      Das betrifft dich aber ohnehin nur, wenn du eine 2er Lizenz betrteibst. Alles andere läuft doch schon auf Version 3.

     Antworten

    Beitrag von Bernd (209 Beiträge) am Dienstag, 19.Februar.2013, 09:16.
    Re: Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      Haste denn mal nen Tipp, nach was ich suchen muss, um das mit dem neutralen Wert hinzubekommen?

     Antworten

    Beitrag von Paßwortschutz (4 Beiträge) am Dienstag, 19.Februar.2013, 09:54.
    Re: Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      Der Tip wäre wohl, dass nicht zu suchen sondern zu programmieren.

      Entweder neu oder die Teile aus der Bib entsprechend erweitern/anpassen.

     Antworten

    Beitrag von Claus (4636 Beiträge) am Dienstag, 19.Februar.2013, 10:45. WWW: h
    Re: Re: Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      hatte ich doch schon geschrieben....

      Bibliothek!!


      e251 - Passwortschutz mit SID, Nutzerverwaltung für einen oder mehrere Datensätze von Claus (-Dieter Jürgens) am 22.2.2005, 14:27 (550)


      Da wird nur noch der Name und eine Session verwendet, alles was ich danach seit 2005 noch für V2 geändert habe ist nur noch für eigene Dinge bei meiner Liz. V2 und Kunden, die ebenfalls noch damit arbeiten oder nicht den bp-Standar PW haben/nutzen wollen....


      Gruesse

      Claus

     Antworten

    Beitrag von Bernd (209 Beiträge) am Mittwoch, 20.Februar.2013, 13:11.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      Hallo Claus,

      hattest recht, deine Lösung aus der Bibliothek ist echt super, Danke.
      Bin auch gerade mehr oder weniger am ampassen.

      Ich möchte vermeiden, dass man mehrere Einträge mit dem selben "Nickname" hat. Beim eintragen oder ändern soll geschaut werden, ob er schon vergeben ist.Wenn nicht = Fehlermeldung.

      Hatte diesen Codeschnipsel im Forum gefunden:

      get "Nickname==$Nickname", "adressen";
       
      if ($_amount_query > 0)
      {
       out "den gibts schon";
      undef %_put;
      }
      

      http://forum.baseportal.de/cgi-bin/baseportal.pl?htx=/baseportal/forum&wcheck=1&Pos=8088.02

      Ich vermute, dass der Codeschnipsel richtig ist, weiß aber nicht, an welcher Stelle ich ihn einsetzen muss.

      Kannst du mir da bitte helfen?

      Danke
      Bernd

     Antworten

    Beitrag von Bernd (209 Beiträge) am Mittwoch, 20.Februar.2013, 15:30.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      So:
      Habe das hier im Forum von Sander gefunden.
      Klappt, läßt keinen neuen Eintrag mit einem bestehenden Nickname zu,
      aber eine Änderung eines bestehenden Eintrags geht auch nicht!

      Verzweiflung macht sich breit ;-(


      http://forum.baseportal.de/cgi-bin/baseportal.pl?htx=/baseportal/forum&wcheck=1&Pos=5526.5
      if(%_put)
      {
      $Nickname=$_put{Nickname}; # Der Name wird in Nickname gesichert
      $Nickname=~s/ /\\ /g; 
      get "Nickname==$Nickname", "data"; #datensätze holen
      if ($_amount>0 && $Nickname eq $_put{Nickname}) {
      out "<b>Eintrag bereits vorhanden!<b><br><br><br>";
      undef %_put;
      }
      }
      

     Antworten

    Beitrag von Claus (4636 Beiträge) am Mittwoch, 20.Februar.2013, 15:57. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem mit PW Bereich


      Jaja, alles nicht so einfach...;)


      ändere das mal so:

      get "Nickname==$Nickname", "adressen";
       
      if ($_amount_query > 0 && $cmd eq "add")
      {
       out "den gibts schon";
      undef %_put;
      $cmd="";
      }
      


      hth


      Gruesse


      Claus

      PS: irgendwann wird das kostenpflichtig...;)

     Antworten

    Beitrag von Bernd (209 Beiträge) am Mittwoch, 20.Februar.2013, 16:21.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Problem mit PW Bereich

      Hallo Claus,
      erstmal vielen Dank, scheint zu funktionieren!!

      Der Abend ist gerettet.
      Bernd

     Antworten


     
 Liste der Einträge von 3150 bis 3300:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.31s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!