Re: Re: Re: bilder per mail-befehl - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Sander (8082 Beiträge) am Sonntag, 29.September.2013, 12:16.
    Re: Re: Re: bilder per mail-befehl

      was ist an 4-8 Zeilen schwer verständich? ;)

      normal ist es aber nur mit dem Header auch nicht gemacht. Binärdaten müssen verschlüsselt werden (base64 oder so was).

      Weiterhin kannst du mit dem header einsetzen auch nur das Bild absenden und kein Text dazu. Wenn du das machen willst, ists verdammt aufwendig, den header und den mailbody zu erstellen.


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Claus (4644 Beiträge) am Samstag, 28.September.2013, 14:55. WWW: hammoniaweb.com
    bilder per mail-befehl

      Hatte jetzt mal aus aktuellem Anlass für einen Kunden experimentiert und dabei festgestellt, man kann Bilder auch mit dem mail-Befehl versenden....

      Normalerweise verrate ich ja solche Tricks nicht, aber in diesem Fall gibt es mal wieder die berühmte Ausnahme..;)

      in Bezug auf diese alte Anfrage im Forum:

      http://forum.baseportal.de/cgi-bin/baseportal.pl?htx=/baseportal/forum&wcheck=1&Pos=15586.00005


      also einfach folgendes einfügen:


      Content-type: text/html,image/png\n

      oder eben entsprechend, z.B.

      Content-type: text/html,image/jpg\n

      Content-type: text/html,image/gif\n



      Wünsche allen bplern ein schönes WE und viel Spaß beim Bilderschicken

      Gruesse

      Claus

     Antworten

    Beitrag von Sander (8082 Beiträge) am Samstag, 28.September.2013, 15:13.
    Re: bilder per mail-befehl

      oder du nimmst einfach das mailmodul aus der bib, welches schon seit Jahren dort rumdümpelt ;)

     Antworten

    Beitrag von Claus (4644 Beiträge) am Samstag, 28.September.2013, 15:21. WWW: hammoniaweb.com
    Re: Re: bilder per mail-befehl

      ich vermute mal, das mailmodul aus der bib ist für Newbies schwerer verständlich, als diese eine Zeile beim mailbefehl auszutauschen...;)

      Gruesse

      Claus

     Antworten

    Beitrag von Sander (8082 Beiträge) am Sonntag, 29.September.2013, 12:16.
    Re: Re: Re: bilder per mail-befehl

      was ist an 4-8 Zeilen schwer verständich? ;)

      normal ist es aber nur mit dem Header auch nicht gemacht. Binärdaten müssen verschlüsselt werden (base64 oder so was).

      Weiterhin kannst du mit dem header einsetzen auch nur das Bild absenden und kein Text dazu. Wenn du das machen willst, ists verdammt aufwendig, den header und den mailbody zu erstellen.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Sonntag, 29.September.2013, 14:21. WWW: hammoniaweb.com
    Re: Re: Re: Re: bilder per mail-befehl

      hatte das gestern mal mit Bild oben und Bild unten als Header und footer inklusive text ausprobiert, im thunderbird, kommt dann eine Meldung, ob man externe Inhalte zulassen will, und voila, alles da, Headerbild, text und fotterbild...;)

      Gruesse

      Claus

     Antworten

    Beitrag von Sander (8082 Beiträge) am Sonntag, 29.September.2013, 20:18.
    Re: Re: Re: Re: Re: bilder per mail-befehl

      aber nur als html und kein bild im anhang...

     Antworten

    Beitrag von Claus (4644 Beiträge) am Montag, 30.September.2013, 16:20. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: bilder per mail-befehl

      Die Bilder von Header und footer sind direkt mit dem Text in der mail enthalten und mit Rechtsklick auf das jeweilige Bild kann man "Grafik speichern unter" oder "Grafik kopieren"...;)

      Gruesse

      Claus

     Antworten

    Beitrag von Sander (8082 Beiträge) am Montag, 30.September.2013, 19:31.
    Re: Re: Re: Re: Re: Re: Re: bilder per mail-befehl

      sag ich ja, nur ne html mail... oder hast du da den Mailheader "Content-type: image/..." mit drin?
      Dann funktioniert dein Tipp nämlich nicht.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Montag, 30.September.2013, 19:48. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Re: bilder per mail-befehl

      kurzes Beispiel:

      mail 'kingofpop@jackson.com',
          "Happy birthday, Jacko!",
          "<img src=\"pfadzumbild/files/header.png\"> \n\n blablalabersülz \n\n <img src=\"pfadzumbild/files/footer.png\">",
          'hgroeni@firemail.de',
          "Michael Jackson",
          "Herbert Groenemeyer",
          'robbie@williams.de, info@madonna.com, matthias@reim.de',
          'redaktion@bild.de, info@bunte.de',
          "Content-type: text/html,image/png\n";
      

      Wenn ich dann auf Externe Inhalte freigeben klicke ist alles auf dem Schirm, so wie gewünscht...)

      Im thunderbird getestet...

      MS outlook soll mucken aber da ich den nicht selbst habe/benutze, kann ich das selbst damit nicht durchtesten...

      Gruesse

      Claus

     Antworten

    Beitrag von Sander (8082 Beiträge) am Montag, 30.September.2013, 20:19.
    Re: Re: Re: Re: Re: Re: Re: Re: Re: bilder per mail-befehl

      aua... es gibt keine 2 content types in einem header. das gleiche würde im thunderbird passieren, wenn du nur den text/html angibst und dann auch im outlook funktionieren. Scheinbar ignoriert thunderbird den falschen png teil. outlook verhält sich korrekt.

      wenn man mehrere teile zusammen in einer mail schicken will (text+html+anhang/anhänge), muss man mit multiparts und boundaries arbeiten. dazu findet sich viel literatur im netz.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Dienstag, 1.Oktober.2013, 08:09. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: bilder per mail-befehl

     Antworten

    Beitrag von Claus (4644 Beiträge) am Dienstag, 1.Oktober.2013, 08:16. WWW: hammoniaweb.com
    Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: bilder per mail-befehl

      >...wenn du nur den text/html angibst und dann auch im outlook funktionieren.
      

      Das war ja der Anlass , daß es anscheinend nicht funktionert, hatte ich doch alles schon mal weiter unten gepostet, ich schreibe das doch nicht noch 10x immer wieder neu...

      Genau darum ging es hier doch, daß der Text angezeigt wurde aber eben kein!! Bild:

      http://forum.baseportal.de/cgi-bin/baseportal.pl?htx=/baseportal/forum&wcheck=1&Pos=15586.00005

      Wenn lustigerweise auch was falsches funktioniert, ich kann damit gut leben...;)

      Gruesse

      Claus

     Antworten


     
 Liste der Einträge von 2700 bis 2850:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.21s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!