Keine Ausgabe nach Suchbefehl - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Franz (21 Beiträge) am Montag, 11.Juni.2001, 11:09.
    Keine Ausgabe nach Suchbefehl

      Mein Wunsch ist:
      Baseportal soll zuerst nur die Suchmaske (ohne Taskleiste "Neu Auswahl Suchen ...) anzeigen und erst nach Eingabe der Suchkriterien die entsprechende Liste ausgeben.

      Meine bisherige Erfahrung ist, erst nach anzeigen der Tabelle funktioniert das Suchen. Aber dieses Anzeigen muß ich verhindern, da die Zieldatenbank (nicht das Beispiel) ca. 1000 Einträge beinhaltet.

      Wie müßte der nachfolgende Befehl aussehen um dies zu erreichen?

      <do action=list db=uebung searchfields=Orte,Farben listtype=search listfields=Orte,Farben,Tiere> <br>
      

      Aurfuf: http://baseportal.de/cgi-bin/baseportal.pl?htx=/liane/uebung

      Vielen Dank für Eure Hilfe

      Franz


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Franz (21 Beiträge) am Montag, 11.Juni.2001, 11:09.
    Keine Ausgabe nach Suchbefehl

      Mein Wunsch ist:
      Baseportal soll zuerst nur die Suchmaske (ohne Taskleiste "Neu Auswahl Suchen ...) anzeigen und erst nach Eingabe der Suchkriterien die entsprechende Liste ausgeben.

      Meine bisherige Erfahrung ist, erst nach anzeigen der Tabelle funktioniert das Suchen. Aber dieses Anzeigen muß ich verhindern, da die Zieldatenbank (nicht das Beispiel) ca. 1000 Einträge beinhaltet.

      Wie müßte der nachfolgende Befehl aussehen um dies zu erreichen?

      <do action=list db=uebung searchfields=Orte,Farben listtype=search listfields=Orte,Farben,Tiere> <br>
      

      Aurfuf: http://baseportal.de/cgi-bin/baseportal.pl?htx=/liane/uebung

      Vielen Dank für Eure Hilfe

      Franz

     Antworten

    Beitrag von Sander (8126 Beiträge) am Montag, 11.Juni.2001, 11:38.
    Re: Keine Ausgabe nach Suchbefehl

      kopier den Quelltext aus der Seite und füge ihn in ein extra Template ein. in den <form action.> tag kommt als ziel das Template mit der Tabellenausgabe.

      Sander

     Antworten

    Beitrag von Franz (21 Beiträge) am Montag, 11.Juni.2001, 16:21.
    Re: Keine Ausgabe nach Suchbefehl

      Irgendwie bin ich zu blöd dies zu verstehen.

      ich hab jetzt folgendes gemacht und es geht immer noch nicht:

      1. "do action=list...." in ein eigenes Template geschrieben (http://baseportal.de/cgi-bin/baseportal.pl?htx=/liane/Template)

      2. wie Du geschrieben hast, im action form... das Template aufgerufen.

      <html><head><title>Rosenheim/suchen</title>
      <head></head>
      <body bgcolor="#ffffff" LINK="#ff0000" VLink="#551A8B" ALINK="#008080" marginheight="10" marginwidth="0" leftmargin="0" topmargin="10">
      </head><br>
      

      <table width=93% border=0 cellpadding=0>
      <tr> 
      <td>
      <table width=100% cellpadding=5 bgcolor=#eaf4d9 align=left>
      <tr><td>
      <b>Nach folgenden Angaben suchen:</b><br>
      <br>
      <table width=100% cellpadding=2 bgcolor=#eaf4d9 border=0><tr>
      <form action="http://baseportal.de/cgi-bin/baseportal.pl?htx=/liane/Template&cmd=search" method="post" enctype="multipart/form-data">
      

      <input type=hidden name="htx=" value="/liane/uebung">
      <input type=hidden name="cmd=" value="search">
          
      <tr>
      <td align=right valign=top>
       Orte:</td>
      <td><select name="Orte~=" size=1><option><option>München<option>Nürnberg<option>Bonn</select><br><font size=1>
      <br></td>
      </tr>
      

      <tr>
      <td align=right valign=top>
       Farben:</td>
      <td><select name="Farben~=" size=1><option><option>rot<option>gelb</select><br><font size=1>
      <br></td>
      </tr>
      

      <tr><td></td><td nowrap>
      <input type=submit value="Suchen">
      <input type=reset value="Zurücksetzen"> 
      </td></tr></form></table>
      </td></tr></table>
      

      </td></tr></table></body></html>


      Bitte um Hilfe, Danke im voraus

      Franz

     Antworten

    Beitrag von anonym (129 Beiträge) am Montag, 11.Juni.2001, 17:56.
    Re: Keine Ausgabe nach Suchbefehl

      Da ist bestimmt ein Schreibfehler drin, der Tag sollte so aussehen:

      <do db=uebung action=list>
      

     Antworten

    Beitrag von Franz (21 Beiträge) am Dienstag, 12.Juni.2001, 08:56.
    Re: Keine Ausgabe nach Suchbefehl

      Hallo Sander, hallo Titus,

      es funktioniert!
      Herzlichen Dank für Eure Hilfe.
      Bin nun einen großen Schritt weiter gekommen.

      Franz

     Antworten

    Beitrag von Sander (8126 Beiträge) am Montag, 11.Juni.2001, 18:31.
    Re: Keine Ausgabe nach Suchbefehl

      hab vergessen:

      <input type=hidden name="htx=" value="/liane/Template">
      

      hier muß das Template auch geändert werden.

      Sander

     Antworten


     
 Liste der Einträge von 61200 bis 61350:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.11s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!