russisches problem - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von markus (989 Beiträge) am Montag, 10.Oktober.2011, 03:05.
    russisches problem

      hallo,
      hab das erste mal mit russischen db inhalten zu tun.
      rufe ich die einträge mit do action ... auf wird alles korrekt angezeigt.

      wenn ich direkt in einem template schreibe oder einträge mit loop oder perl ausgeben möchte, bekomme ich u.a. sowas:
      новости
      

      jemand nen tipp?
      markus


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von markus (989 Beiträge) am Montag, 10.Oktober.2011, 03:05.
    russisches problem

      hallo,
      hab das erste mal mit russischen db inhalten zu tun.
      rufe ich die einträge mit do action ... auf wird alles korrekt angezeigt.

      wenn ich direkt in einem template schreibe oder einträge mit loop oder perl ausgeben möchte, bekomme ich u.a. sowas:
      новости
      

      jemand nen tipp?
      markus

     Antworten

    Beitrag von Claus S. (1671 Beiträge) am Montag, 10.Oktober.2011, 11:51.
    Re: russisches problem

      Hallo Markus,

      hatte das Problem auch, ist eine Frage des Zeichensatzes.
      Kopiere den Quellcode in einen Einfacheditor, z.B. Windows Editor, und speichere ihn unter UTF-8 ab. Zudem noch im Quelltext
      <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
      
      einfügen.

      So sollte es funktonieren.
      Beispiel: http://www.badener-weinkeller.de/index_ru.html

      Gruss

      Claus S.

     Antworten

    Beitrag von markus (989 Beiträge) am Mittwoch, 12.Oktober.2011, 03:50.
    Re: Re: russisches problem

      hi,

      habe beide meta ausprobiert, ohne erfolg.

      bei der db ausgabe klappt es ja auch mit:
      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
      


      bei einer lizenz läuft es damit, da laufen ca. 13 sprachen:

      <?xml version="1.0" encoding="iso-8859-1"?>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      

      <html lang="de" xml:lang="de" xmlns="http://www.w3.org/1999/xhtml">

       <head>
      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-5">>
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      

      hat es evtl. was mit der miete zu tun?
      markus

     Antworten

    Beitrag von markus (989 Beiträge) am Mittwoch, 12.Oktober.2011, 04:46.
    Re: Re: Re: russisches problem

      hab vermutlich das problem gefunden.
      ist irgendwas mit meiner css, denn in der smartphone site wird alles
      ordentlich ausgegeben.
      thanx
      markus

     Antworten

    Beitrag von Sander (8087 Beiträge) am Mittwoch, 12.Oktober.2011, 10:41.
    Re: Re: Re: russisches problem

      2x content-type ist definitv falsch. was soll der browser damit anfangen?
      Hast du vielleicht mal einen Link dahin?

     Antworten

    Beitrag von markus (989 Beiträge) am Donnerstag, 13.Oktober.2011, 11:17.
    Re: Re: Re: Re: russisches problem

      klar, 2x content-type passt nicht.
      lag definitiv an der css, warum auch immer?!
      de & gb klappte damit einwandfrei.
      danke
      markus

     Antworten

    Beitrag von mk (966 Beiträge) am Dienstag, 25.Oktober.2011, 14:52. WWW: vokabeltrainer-online.net
    Re: Re: Re: Re: Re: russisches problem

      @markus
      

      Ich bin im Moment auch am Russischen drann, habs mit baseportal hin bekommen.
      Schwierig ist dafür die richtige CSS zu erzeugen.

      Was soll es denn werden bei dir?
      Ich suche Russische Unterstützung.

     Antworten

    Beitrag von Claus (4644 Beiträge) am Dienstag, 11.Oktober.2011, 22:36. WWW: hammoniaweb.com
    Re: russisches problem

      eigentlich ist nur entscheidend, wie die Daten in die DB geschrieben werden....

      siehe z.B.

      http://www.kriegstote.org/cgi-bin/baseportal.pl?htx=/Russisch/vtsuche3

      wenn Du die Seite mal im Quelltext anschaust, wirst Du dort ähnliche Zeichen sehen, aber die Ausgabe ist korrekt...

      Da ist im Head folgender Zeichensatz angegeben:

      <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
      


      Schau es Dir an und probier mal, ob es bei Dir funktioniert.

      Auch alle get-Ausgaben werden korrekt ausgegeben...;)

      hth

      Gruesse

      Claus

     Antworten

    Beitrag von Claus (4644 Beiträge) am Dienstag, 11.Oktober.2011, 22:44. WWW: hammoniaweb.com
    Re: Re: russisches problem

      Ist übrigens einer meiner Kunden mit vielen Informationen über den 1. und 2. Weltkrieg auf der Seite

      http://www.kriegstote.org/

      ein wenig Werbung muß auch sein...;)

      Gruesse

      Claus

     Antworten


     
 Liste der Einträge von 4650 bis 4800:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.56s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!