Re: @sander - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Claus (1 Beitrag) am Sonntag, 29.April.2001, 22:47.
    @profis: verzwickter fehler :-(

     Antworten

    Beitrag von Sander (8126 Beiträge) am Sonntag, 29.April.2001, 23:13.
    Re: @profis: verzwickter fehler :-(

      Das haut nicht hin:
      <loop db=gpurl>
      

      <perl>
      $urlgo="http://www.baseportal.de";
      $urltitel="test baseportal";
      </perl>
      

      <loop code=perl db=gpurl>
      und dann mit EOF arbeiten

      Sander

     Antworten

    Beitrag von Claus (4645 Beiträge) am Sonntag, 29.April.2001, 23:25.
    Re: @profis: verzwickter fehler :-(

      danke sander,
      verstehe ich aber nicht, in dem bibliotheksbeispiel funzt das doch auch und die richtigen felder werden gefüllt. was mich wundert, das der link nicht gefüllt wird

     Antworten

    Beitrag von Claus (4645 Beiträge) am Sonntag, 29.April.2001, 23:53.
    Re: @sander

     Antworten

    Beitrag von Stefan Krupop (311 Beiträge) am Montag, 30.April.2001, 00:08.
    Re: @sander

      Hi!

      Ich denke das
      $urlgo="http://www.baseportal.de";
      $urltitel="test baseportal";
      gehört vor das out <<EOF;
      

      Stefan

     Antworten

    Beitrag von Claus (4645 Beiträge) am Montag, 30.April.2001, 00:31.
    Re: @sander

     Antworten

    Beitrag von Sander (8126 Beiträge) am Montag, 30.April.2001, 00:50.
    Re: @sander

      Wie sieht denn der Inhalt des Feldes aus?

      Sander

     Antworten

    Beitrag von Stefan Krupop (311 Beiträge) am Montag, 30.April.2001, 00:51.
    Re: @sander

     Antworten

    Beitrag von Claus (4645 Beiträge) am Montag, 30.April.2001, 01:13.
    Re: @sander + stefan

     Antworten

    Beitrag von Sander (8126 Beiträge) am Montag, 30.April.2001, 01:41.
    Re: @sander + stefan

      das Feld muß Text sein, weil Link automatisch a href dazu dichtet. Das sollte es dann sein.

      Sander

     Antworten

    Beitrag von Claus (4645 Beiträge) am Montag, 30.April.2001, 01:42.
    Re: @sander + stefan

      hallo,
      ich glaube, ich bin der sache auf der spur:
      die bib-version gibt
      $urlgo="http://baseportal.de"; vor, während ich mit einem feldinhalt arbeite
      $urlgo=$gpurl;
      
      und da dieses feld mit bp-typ link definiert ist, steht wohl "href..." auch mit drin.
      habe jetzt mal testweise das feld in der datei als textfeld umdefiniert, dann steht nur noch "www.baseportal.de" drin, dann musste ich allerdings noch "http://" davorsetzen. damit funktioniert es.
      ist das so ok oder gibt es eine effektivere lösung?
      gruss claus

     Antworten

    Beitrag von Sander (8126 Beiträge) am Montag, 30.April.2001, 14:23.
    Re: @sander + stefan

      mann kan das automatisieren.
      <loop code=perl>
      $urlgo=~ s#^http://##;
      out "<a href=http://baseportal.de/cgi-bin/baseportal.pl?htx/gpark/gpclic2&urlgo=http://$urlgo&urltitel=$urltitel target=_blank>$urltitel</a>";
      </loop>
      

      Dann ist es egal wie es in der db im Textfeld drin steht.

      Sander

     Antworten

    Beitrag von ClausS (5 Beiträge) am Montag, 30.April.2001, 16:32.
    Re: @sander + stefan

      sorry sander, aber das hab ich nicht verstanden

      in der datei steht die url als feld GPURL und nachdem ich den Typ LINK in TEXT geändert habe, steht jetzt z.b. "www.basebortal.de" drin (mit dem typ LINK gibt es ja, wenn ich das verstaden habe, keine lösung).

      was bedeutet das ~ s#^... ?
      und kann ich dann auf die zwischenvariable $urlgo verzichten? oder wie meinst du das?

     Antworten

    Beitrag von fb (420 Beiträge) am Montag, 30.April.2001, 17:41.
    Re: @sander + stefan

      Hallo ClausS,
      hab gerade was in die BIB gestellt, kleines tool.
      Ist zwar nicht genau das was Du brauchst, aber kann Dir helfen.
      Hintergrund ist das beim verwenden eines Textfeldes als Link, der Eintrag unbedingt das http:// vorneweg haben muss (also absolut verweisen). Ist ja eigentlich genau wie auf dem HP server. Du befindest Dich ja bei BP, heisst der link ist ohne http:// ein relativer verweis.

      FB

     Antworten

    Beitrag von Sander (32 Beiträge) am Montag, 30.April.2001, 18:57.
    Re: @sander + stefan

      <loop code=perl>
      $Feldname=~ s#^http://##;  # hier wird von dem Feldname aus der db das http abgeschnitten falls vorhanden
      out "<a href=http://baseportal.de/cgi-bin/baseportal.pl?htx/gpark/gpclic2&urlgo=http://$Feldname&urltitel=$urltitel target=_blank>$urltitel</a>";
      </loop>
      

      im Link wird ein http:// wieder dafür reingeschrieben.
      $Feldname ist der Name aus der db
      

      Sander

     Antworten

    Beitrag von ClausS (5 Beiträge) am Montag, 30.April.2001, 22:31.
    Re: @sander + stefan, hurra es funzt!!!!!

      hallo sander,
      danke für die hilfe,
      es fehlte zwar noch ein = nach dem htx, das hat mich ne stunde gekostet ;-) aber jetzt läuft es richtig gut

     Antworten


     
 Liste der Einträge von 62700 bis 62850:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.32s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!