Re: Wo liegt der Fehler? - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Tiger (42 Beiträge) am Donnerstag, 21.Juni.2001, 13:22.
    Re: Wo liegt der Fehler?

      hab ich vorher schon probiert, geht auch nicht... :(
      Hier nochmal der komplette Quellcode der Site:
      <html>
      <head>
      <do action=input> 
      <title>Cultkalender.de - Das Schülermagazin ::: V 3.0</title>
      <!--#include file="www/spicken.de/essef-infurt/scripts/head.txt"-->
      <!--#include file="www/spicken.de/essef-infurt/scripts/werbung.txt"-->
      <div id="druck">
      <!-- ==> Ab hier Text einfügen!!! <== -->
            <p><font size="3" face="Arial">
            <strong><div align="left" >Cultkalender.de Userbereich - LogIn</div></strong>
            </font></p>
            <font size="2" face="Arial">
      <perl>
      if($namerein ne "")
      {
       get "Name==!$namerein", "nutzer";
      
       if($Passwort ne "" && $Passwort eq $pwrein)  {  #do_all "", "namerein", "pwrein"; #
      out <<EOF;
       <form action="http://www.baseportal.de/cgi-bin/baseportal.pl?htx=/Tiger/user/danke&cmd=add" method=post enctype="multipart/form-data">
      <input type="hidden" name="cmd=" value="add">
      <input type="hidden" name="htx=" value=danke>
      <input value="$eMail" name="eMail:=" type="hidden">
      <input value="$Name" name="Name:=" type="hidden">
      <input value="$_REMOTE_ADDR" name="IP:=" type="hidden">
      <table border="0">
          <tr>
              <td>Titel:</td>
              <td><input type="Text" name="Titel:=" value="" size="56" maxlength=""></td>
          </tr>
          <tr>
              <td>Einleitung</td>
              <td><textarea name="Absatz:=" cols="50" rows="3"> </textarea></td>
          </tr>
          <tr>
              <td>Text</td>
              <td><textarea name="Text:=" cols="50" rows="10"> </textarea></td>
          </tr>
          <tr>
              <td>Typ</td>
              <td> </td>
          </tr>
      </table>
      <p>
      <input type="submit" value="Speichern">
      </form>
      EOF
      } else
       {
        out "<b>Anmeldung fehlgeschlagen!</b>";
       }
      }
      if($namerein eq "")
      {
      out <<EOF;
      <h2>Bitte melde Dich an:</h2>
      <form enctype="multipart/form-data" action="http://baseportal.de/cgi-bin/baseportal.pl?htx=$htx" method="post">
      <input type=hidden name="htx=" value="$htx">
      <table >
      <tr>
       <td>Name:</td>
       <td><input type="text" name="namerein="> </td>
      </tr>
      <tr>
       <td>Passwort:</td>
       <td><input type="password" name="pwrein="> </td>
      </tr>
      <tr>
       <td> </td>
       <td><input type="Submit" value="Anmelden"> </td>
      </tr>
      </table>
      </form>
      EOF
      }
      </perl>
            </font>
            </div>
            </textarea></form>
      <!-- Ende Textarea -->
            </td>
            <td align="right" valign="top" rowspan="15" width="20"><img
              src="Bilder/e2.gif"
              width="20" height="20"></td>
            <td valign="top" colspan="2" width="120"
              bgcolor="#000000"> </td>
        </tr>
      <!-- Ende Text -->
      
      [...]
      </body>
      </html>
      


    Ihre Antwort:

    Name: EMail: EMail bei Antwort? WWW:
    Titel:
    Text:

    Neuer Eintrag


 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Tiger (42 Beiträge) am Donnerstag, 21.Juni.2001, 11:59.
    Wo liegt der Fehler?

      Hallo!
      Wenn ich versuche, folgendes Formular abzuschicken:
      out <<EOF;
      
       <form action="http://www.baseportal.de/cgi-bin/baseportal.pl?htx=/Tiger/user/danke&cmd=add" method=post enctype="multipart/form-data">
      <input type="hidden" name="cmd=" value="add">
      <input type="hidden" name="htx=" value="/danke">
      <input value="$eMail" name="eMail:=" type="hidden">
      <input value="$Name" name="Name:=" type="hidden">
      <input value="$_REMOTE_ADDR" name="IP:=" type="hidden">
      <table border="0">
          <tr>
              <td>Titel:</td>
              <td><input type="Text" name="Titel:=" value="" size="56" maxlength=""></td>
          </tr>
          <tr>
              <td>Einleitung</td>
              <td><textarea name="Absatz:=" cols="50" rows="3"> </textarea></td>
          </tr>
          <tr>
              <td>Text</td>
              <td><textarea name="Text:=" cols="50" rows="10"> </textarea></td>
          </tr>
          <tr>
              <td>Typ</td>
              <td> </td>
          </tr>
      </table>
      <p>
      <input type="submit" value="Speichern">
      </form>
      EOF
      

      gibt's folgende Fehlermeldung:
      [ Fehler: run: /usr/local/httpd/data/danke.htx kann nicht zum Lesen geöffnet werden.
      Ursache: Die angegebene Ausgabeseite existiert nicht. Vielleicht haben Sie sich nur verschrieben?

      Lösungen: 1. Korrigieren Sie Ihre Abfrage. 2. Gehen Sie in Ihren privaten Bereich (Anmelden) und legen Sie eine entsprechende Seite an. ]

      Was mache ich falsch?
      MfG
      Christian
      P.S.: Eine Ausgabesite "danke" gibts im selben Verzeichnis. (/Tiger/user/danke)

      Verwende eigene Schlechtschreibung :)

     Antworten

    Beitrag von Sander (8133 Beiträge) am Donnerstag, 21.Juni.2001, 12:24.
    Re: Wo liegt der Fehler?

      der slash bei htx ist zu viel
      value=danke wenn im selben verzeichnis

      Sander

     Antworten

    Beitrag von Tiger (42 Beiträge) am Donnerstag, 21.Juni.2001, 13:22.
    Re: Wo liegt der Fehler?

      hab ich vorher schon probiert, geht auch nicht... :(
      Hier nochmal der komplette Quellcode der Site:
      <html>
      <head>
      <do action=input> 
      <title>Cultkalender.de - Das Schülermagazin ::: V 3.0</title>
      <!--#include file="www/spicken.de/essef-infurt/scripts/head.txt"-->
      <!--#include file="www/spicken.de/essef-infurt/scripts/werbung.txt"-->
      <div id="druck">
      <!-- ==> Ab hier Text einfügen!!! <== -->
            <p><font size="3" face="Arial">
            <strong><div align="left" >Cultkalender.de Userbereich - LogIn</div></strong>
            </font></p>
            <font size="2" face="Arial">
      <perl>
      if($namerein ne "")
      {
       get "Name==!$namerein", "nutzer";
      
       if($Passwort ne "" && $Passwort eq $pwrein)  {  #do_all "", "namerein", "pwrein"; #
      out <<EOF;
       <form action="http://www.baseportal.de/cgi-bin/baseportal.pl?htx=/Tiger/user/danke&cmd=add" method=post enctype="multipart/form-data">
      <input type="hidden" name="cmd=" value="add">
      <input type="hidden" name="htx=" value=danke>
      <input value="$eMail" name="eMail:=" type="hidden">
      <input value="$Name" name="Name:=" type="hidden">
      <input value="$_REMOTE_ADDR" name="IP:=" type="hidden">
      <table border="0">
          <tr>
              <td>Titel:</td>
              <td><input type="Text" name="Titel:=" value="" size="56" maxlength=""></td>
          </tr>
          <tr>
              <td>Einleitung</td>
              <td><textarea name="Absatz:=" cols="50" rows="3"> </textarea></td>
          </tr>
          <tr>
              <td>Text</td>
              <td><textarea name="Text:=" cols="50" rows="10"> </textarea></td>
          </tr>
          <tr>
              <td>Typ</td>
              <td> </td>
          </tr>
      </table>
      <p>
      <input type="submit" value="Speichern">
      </form>
      EOF
      } else
       {
        out "<b>Anmeldung fehlgeschlagen!</b>";
       }
      }
      if($namerein eq "")
      {
      out <<EOF;
      <h2>Bitte melde Dich an:</h2>
      <form enctype="multipart/form-data" action="http://baseportal.de/cgi-bin/baseportal.pl?htx=$htx" method="post">
      <input type=hidden name="htx=" value="$htx">
      <table >
      <tr>
       <td>Name:</td>
       <td><input type="text" name="namerein="> </td>
      </tr>
      <tr>
       <td>Passwort:</td>
       <td><input type="password" name="pwrein="> </td>
      </tr>
      <tr>
       <td> </td>
       <td><input type="Submit" value="Anmelden"> </td>
      </tr>
      </table>
      </form>
      EOF
      }
      </perl>
            </font>
            </div>
            </textarea></form>
      <!-- Ende Textarea -->
            </td>
            <td align="right" valign="top" rowspan="15" width="20"><img
              src="Bilder/e2.gif"
              width="20" height="20"></td>
            <td valign="top" colspan="2" width="120"
              bgcolor="#000000"> </td>
        </tr>
      <!-- Ende Text -->
      
      [...]
      </body>
      </html>
      

     Antworten

    Beitrag von Sander (8133 Beiträge) am Donnerstag, 21.Juni.2001, 16:01.
    Re: Wo liegt der Fehler?

      Dann schreib halt den kompletten Pfad rein:
      /user/verzeichnis/template

      Sander

     Antworten

    Beitrag von Tiger (42 Beiträge) am Donnerstag, 21.Juni.2001, 16:29.
    Re: Wo liegt der Fehler?

      jo. jetzt gehts. danke. :)
      gruß
      chris
      p.s.: vielleicht sollte man das in der doku auch ändern?
      <form action="http://www.baseportal.de/cgi-bin/baseportal.pl?htx=/Benutzername/Verzeichnis/Template&cmd=add" method=post enctype="multipart/form-data">
      <input type="hidden" name="cmd=" value="add">
      <input type="hidden" name="htx=" value="namedestemplates">
      
      zu
      <input type="hidden" name="htx=" value="/Benutzername/Verzeichnis/Template">


      Verwende eigene Schlechtschreibung :)

     Antworten

    Beitrag von daniel (83 Beiträge) am Freitag, 22.Juni.2001, 09:53.
    FORM überträgt Parameter nicht

      Folgender 'Quältext' :

      <perl>
      if ($XLOGIN eq "")
      {out <<EOF;
      <body background="http://www.worldletter.com/pictures/snow.jpg">
      <blockquote>
      <br><br><br><br><br><br><br><br>
      <h3>Login</h3>
      <form action="baseportal.pl?htx=/unagmbh/WL/login" method="post" enctype="multipart/form-
      data" target="_top">
      <p>
      <b>Username :</b><br>
      <input type="Text" name="XLOGIN"><br><br>
      <b>Password :</b><br>
      <input type="Password" name="XPWD"><br><br>
      <input type="Submit" name="go" value="Anmelden">
      </p>
      </form>
      </blockquote>
      </body>
      EOF
      }
      else
      {out <<EOF;
      <body background="http://www.worldletter.com/pictures/snow.jpg">
      EOF
      get "LOGIN==!$XLOGIN", "USER"; 
      if($PSW ne "" && $PSW eq $XPWD)
      {
       out "Alles OK"
      } else
      {
        out "Ne !";
      }
      out "</body>";
      }
      </perl>
      

      die parameter für XLOGIN und XPWD kommen nicht an ,wenn ich sie in der URL mitschicke funktionierts ,was aber für Passwörter nicht so toll wäre :-)

      was mach' ich FALSCH

     Antworten

    Beitrag von Sander (8133 Beiträge) am Freitag, 22.Juni.2001, 09:57.
    Re: FORM überträgt Parameter nicht

      es fehlt das = hinter den Feldnamen.
      <input type="Text" name="XLOGIN=">
      

      Sander

     Antworten

    Beitrag von daniel (83 Beiträge) am Freitag, 22.Juni.2001, 10:03.
    Re: FORM überträgt Parameter nicht

      Auch das hab ich probiert ...ändert nichts..:-(

     Antworten

    Beitrag von Sander (8133 Beiträge) am Freitag, 22.Juni.2001, 10:26.
    Re: FORM überträgt Parameter nicht

      dann mach mal das noch dazu
      <input type="hidden" name="htx=" value=/user/verz/template>
      

     Antworten

    Beitrag von daniel (83 Beiträge) am Freitag, 22.Juni.2001, 10:40.
    Re: FORM überträgt Parameter nicht

      Auch das nützt nichts...

      Die Seite wird ja gefunden,nur die parameter sind leer
      (die if ($XLOGIN eq "") bleibt true)

      Wofür steht eigentlich 'cmd=add' in der URL bzw. der zusätzliche Hidden-Tag ? und ist das in diesem Fall (ich will ja nichts hinzufügen sondern nur vergleichen) notwendig ?
      Oder muss statt add ein anderer wert angegeben werden ?

     Antworten

    Beitrag von Daniel (84 Beiträge) am Donnerstag, 21.Juni.2001, 16:21.
    Re: Wo liegt der Fehler?

      Wenn's dich tröstet das ich mit dem selben Problem rumschlage :-)

     Antworten


     
 Liste der Einträge von 60900 bis 61050:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.14s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!