Re: Datumssortierung fehlerhaft? Parameterklammer - baseportal Forum - Web-Anwendungen einfach, schnell, leistungsfähig!
baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Sascha Fitzner (476 Beiträge) am Samstag, 6.Januar.2001, 17:53.
    Re: Datumssortierung fehlerhaft? Parameterklammer

      Hallo!
      So wie es scheint habe ich den Bock gefunden.
      Ich habe jetzt im do den sort von
      sort=-hat_am
      auf
      sort=-{hat_am} geändert.
      jetzt scheint die Sortierung zu stimmen.

      Warum? Keine Ahnung.

      Sascha


    Antworten

 Alle Einträge zum Thema: Zur Liste 
    Beitrag von Sascha Fitzner (476 Beiträge) am Samstag, 6.Januar.2001, 17:35.
    Datumssortierung fehlerhaft?

      Ich habe irgendwann im Dezember eine Tabelle angelegt. In dieser Tabelle kommt ein Datumsfeld vor. Leider habe ich den Feldnamen mit "hat am" angelegt (Leerschritt). Dieses habe ich heute geändert in dem ich in die Felder gegangen bin und aus "hat am" ein "hat_am" (Underline) gemacht habe. Vorher hatte das Feld die folgenden Eigenschaften:
      Feld="hat am"
      Sortierung="---"
      Typ=Datum
      Eingabe=Zeitpunkt Erstellung,
      Ausgabe=$t0.$m0.$j0, $s0:$mi0

      nach der Änderung (wohlgemerkt ich wollte eigentlich nur den Feldnamen ändern) habe ich

      Feld="hat_am"
      Eingabe=Tag.Monatname.Jahr, Stunde:Minute
      Ausgabe=Wochentag, Tag.Monatname.Jahr, Stunde:Minute, Zeitpunkt=Erstellung

      und jetzt habe ich ein gravierendes Problem:

      Sortiere ich den Inhalt der Tabelle nach diesem Feld absteigend, kommt folgende Ausgabe.

      Jüngster Alteintrag
      2.-jüngster Alteintrag
      3.-jüngster Alteintrag
      n.-jüngster Alteintrag
      Jüngster Neueintrag
      2.-jüngster Neueintrag
      3.-jüngster Neueintrag
      n.-jüngster Neueintrag

      brauche dringend Hilfe!

      Was ich noch sehr merkwürdig finde, ist die Tatsache das alle Felder in der Ausgabetabelle linksbündig ausgegeben werden, nur das Feld "hat_am" nicht. dieses Feld ist das einzigste das in der <do> tabelle rechtsbündig ausgegeben wird obwohl die ausgabe aller feldinhalte linksbündig definiert wurde.

     Antworten

    Beitrag von Sascha Fitzner (476 Beiträge) am Samstag, 6.Januar.2001, 17:53.
    Re: Datumssortierung fehlerhaft? Parameterklammer

      Hallo!
      So wie es scheint habe ich den Bock gefunden.
      Ich habe jetzt im do den sort von
      sort=-hat_am
      auf
      sort=-{hat_am} geändert.
      jetzt scheint die Sortierung zu stimmen.

      Warum? Keine Ahnung.

      Sascha

     Antworten


     
 Liste der Einträge von 66300 bis 66450:Einklappen Zur Eingabe 
Neueste Einträge << 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | Neuere Einträge < Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.28s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!