baseportal
English - Deutsch "Es gibt keine dummen Fragen - jeder hat einmal angefangen"

 baseportal-ForumDie aktuellsten 10, 30, 50, 100 Einträge anzeigen.  

 
 Ausgewählter Eintrag: Zur Liste 
    Beitrag von Peter (273 Beiträge) am Donnerstag, 11.Oktober.2018, 17:39.
    get-Problem

      Hallo Sander,

      nach stundenlanger Fehlersuche folgendes gefunden.

      Die erste Variante wird sauber interpretiert:

        $not   = " \& EMail\<\>!_";
        $_get_sort="Name";
        $select="Name==*";
        if($cb1   eq "true"){$select=$select.' & rEinsteller==1';}
        if($cb2   eq "true"){$select=$select.' & rSchule==1';}
        if($cb3   eq "true"){$select=$select.' & rPrivat==1';}
        $select=$select.$not;
        get $select, "eineDB";
      

      Bei der zweiten verschluckt sich der Interpreter ordentlich:

        $not   = " \& EMail\<\>!_";
        $_get_sort="Name";
        $select="Name==*";
        if($cb1   eq "true"){$select=$select.' & rEinsteller==1';}
        if($cb2   eq "true"){$select=$select.' & rSchule==1';}
        if($cb3   eq "true"){$select=$select.' & rPrivat==1';}
        $select=$select.$not;
        get "$select", "../eineDB";
      

      Was er nicht mag ist der Verweis zurück '../'
      in Kombination mit dem '$not'.


    Ihre Antwort:

    Name: EMail: EMail bei Antwort? WWW:
    Titel:
    Text:

    Neuer Eintrag 

 Liste der ersten 150 Einträge:Einklappen Zur Eingabe 
 Zur Eingabe  > Ältere Einträge | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 >> Älteste Einträge


Zurück zur Homepage

© baseportal.de. Alle Rechte vorbehalten. Nutzungsbedingungen



powered in 0.19s by baseportal.de
Erstellen Sie Ihre eigene Web-Datenbank - kostenlos!